Seite 1 von 1

Probleme mit Baud Rate :-(

Verfasst: 12.05.2006, 09:46:54
von watson
Hallo Ihr,

ich versuche krampfhaft seit ein paar Tagen einen eigenen Kernel zu backen, scheitere aber jedesmal an der Baudrate.
Ulrich hat mir anfang letzter Woche sein LPC2294 Board zugeschickt mit einem 20MHz Quarz.
Der Bootloader kommuniziert noch mit der richtigen Baud Rate (9600) aber mein Kernel will nicht so recht funktionieren.
Würde mir bitte einer sagen was ich wo konfigurieren oder editieren muss, um für meinen Kernel ebenso eine Baud Rate von 9600 zu erreichen?
Meine komplette uClinux ist an allen Stellen so gepatcht, wie man es hier im Forum findet.

Ich wäre für jeden Rat sehr dankbar.

MfG
watson

Verfasst: 12.05.2006, 22:57:07
von Ulrich
Hallo,

Das Board hat einen 12 MHz Quarz für den Prozessor und einen 20 Mhz für die Netzwerkkarte. Die Taktfrequenz wird direkt in der Seriell.h angegeben wie in den anderen Beiträgen beschrieben. Alle anderen unter make menuconfig sollten nicht geändert werden.

Gruss
Ulrich

versuche es, aber es will nicht so wie ich.

Verfasst: 15.05.2006, 10:34:41
von watson
Hi alle,

ich habe versucht die Baud Rate über linux-2.6.x/include/arm/arch/serial.h (linux-2.6.x/include/arm-arch/arch-lpc22xx/serial.h) direkt einzustellen aber es funktioniert dann auch nicht. Ich habe dort den #define direkt auf #define BASE_BAUD 9600 gesetzt und den mit dem LPC22xx_Lcclk / 16 auskommentiert. bin ich da in der korrekten serial.h gelandet oder hab ich mich ein wenig verfahren? ;) Oder mache ich prinzipiell etwas falsch? Danke für eure Hilfe...

MfG
watson

serielles problem gelöst

Verfasst: 15.05.2006, 13:28:59
von watson
hab das baud raten problem fürs erste gelöst... danke schön für die hilfe.

mfg
watson

Verfasst: 16.05.2006, 19:05:22
von Thomas
Wie?

ist kinderleicht :)

Verfasst: 16.05.2006, 21:51:49
von watson
ich musste in keiner serial.h die baudrate oder die quartz frequenz manuell eintragen. allein die richtigen settings in make menuconfig führten zum richtigen ergebnis.

quartz speed: 12000000
CPU Freq: 48000000

...das war es schin, und danach gings.

hoffe du hast genausoviel glück wie ich.

watson